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As in every science field any experimental methodology needs to be validate prior any 
production work! 
 
Therefore in the very first use of the autodock program you will be trained to see if a 
docking program (Autodock 4.0) could be suitable to study the binding mode of a certain 
ligands (docking assessment). Of course for any docking program the goal should be the 
reproduction of the experimental bound conformation of a ligand into its target 
macromolecule (docking assessment). 
 
We will use the (Histone deacetylase 8 / Trichostatin A) HDAC8/TSA complex (PDB 
entry code 1t64) for the docking assessment and to learn how to use Autodock in its rigid 
and flexible modes 

 
 
 
 

 
NOTE. THIS TUTORIAL IS INTENDED TO BE AN INTRODUCTION FOR DOCKING AND HOW TO USE DOCKING 
PROGRAMS. SOME PARTS OF THE TUTORIAL ARE TAKEN FROM AUTODOCK TUTORIALS. 
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Docking Flowchart 
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Overall Steps: 
 

1. Get the complex (CPLX) coordinates (i.e. from the PDB). 
2. Clean the complex (delete all the water and the solvent molecules and all non-

interacting ions). 
3. Add the missing hydrogens/side chain atoms and minimized the complex (AMBER 

Program). 
4. Clean the minimized complex (delete all the water and the solvent molecules and all 

non-interacting ions). 
5. Separate the minimized CPLX in macromolecule (LOCK) and ligand (KEY). 
6. Prepare the docking suitable files for LOCK and KEY (pdbqt files). 
7. Prepare all the needing files for docking (grid parameter file, map files, docking 

parameter files). 
8. Run the docking. 
9. Analyze the docking results. 

 
NOTE. In your home folder you will find the DOCKING folder under which are saved 
all the calculations already done for you. A second folder (MD_files) has been made in 
which you find only the initial files to run all over the tutorial. 
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1. Docking Assessment using the bound ligand conformation: 
 
In this tutorial you will be guided in running docking experiments from the AMBER 
optimized complex. The program VMD will be used to prepare the macromolecule (lock) 
and the inhibitor (key) files.  
Next the program AutoDockTools 1.4.4 (ADT) will be used to prepare the needed files 
and parameters to run the dockings and to analyze the results. 
In the first step we will see if the docking program will be successful in reproducing the 
experimental complex using as starting point the experimental ligand binding conformation 
as found in experimental complex (1t64). 

 

PDB: 1T64  
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1.1. Preparing the pdb file from geometry optimized complex. 
  

1.1.1 Open the 1T64-A_Min.pdb file and read it carefully. 
Use the command less 1T64-A_Min.pdb 

 
1.1.2 Open VMD by typing VMD and hitting the enter key. Browse to the 

MD_files Directory and load the 1T64-A_Min.pdb file: 
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1.1.3 Visualize the Protein and it’s inhibitor: 
         Open graphics – representation 

             Click on the selected atoms field 
      Type: “protein” thin hit the “Enter Key” 
      Click on Draw Style 
      Select New Cartoon as the Drawing method 
      Select COLORID 6 as the coloring method 
      Click on the Create Representation Button 
      Type: “resname INH” in the selected atom field 
             Click on Draw Style 

     Select LICORICE as the Drawing method 
     Select COLORID 4 as the coloring method 
     Click on the Create Representation Button 

      Type: “resname ZN” in the selected atom field 
             Click on Draw Style 

     Select VDW as the Drawing method 
     Select COLORID 7 as the coloring method 
 

  You should get the following representation for the complex: 
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IMPORTANT!! 
If the complex comes directly from the AMBER program also the HIE and HID residue 
have to be fixed into HIS, otherwise ADT (next section) will not recognize them 
correctly.  
 
The lock and key files can be prepare directly in a UNIX shell using some simple UNIX 
commands: 
 
Once checked out the inhibitor residue name (see 1.1.1) the lock and key file can be 
prepared using the cat and grep UNIX commands as following: 
 
 
 
 
 
 
And use VMD to check them all. 
 
 
 

Prompt> cat cplx_filename.pdb | grep INH > key_filename.pdb 
 
Prompt> cat cplx_filename.pdb | grep -v INH | sed 's/HIE/HIS/' | sed 's/HID/HIS/' > lock_filename.pdb 
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1.2. Preparing the file for docking using ADT and run the docking. 
 
1.2.1. Some rules from the ADT online tutorial: 
(http://autodock.scripps.edu/faqs-help/tutorial/using-autodock-4-with-autodocktools) 
 
A) You should always start ADT in the same directory as the macromolecule and ligand 
files. You can start ADT from the command line in a Terminal by typing "adt" and 
pressing <Return> or <Enter>. 
B) For both the macromolecule and the ligand, you should always add polar hydrogens, 
compute Gasteiger charges and then you must merge the non-polar hydrogens. Polar 
hydrogens are hydrogens that are bonded to electronegative atoms like oxygen and 
nitrogen. Non-polar hydrogens are hydrogens bonded to carbon atoms. 
C) You need one AutoGrid map for every atom type in the ligand plus an electrostatics 
map. E.g.: for ethanol, C2H5OH, you would need C, OA and HD maps plus an 
electrostatics 'e' map plus a desolvation 'd' map. 
D) The grid volume should be large enough to at least allow the ligand to rotate freely, 
even when the ligand is in its most fully extended conformation. 
1.2.2. Preparing a ligand file for Autodock. 
 

(Taken from Autodock Tutorials ) 
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Start ADT from a UNIX shell and open a ligand file using the Ligand - Input - 
Open … sequence. 

Set the file type to *.pdb and choose the key file (1t64_key.pdb). Click OK in the 
upcoming  window. 

 

 
Save the file as pdbqt (Ligand, Output, Save as PDBQT…) giving a proper name 
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(1t64_key.pdbqt) and check the written file. 
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1.2.3. Preparing the macromolecule file. 
Open a macromolecule file using the Grid - Macromolecule - Open … sequence. 
Set the file type to *.pdb and choose the lock file (1t64_lock.pdb). Click OK in the 
upcoming window. Ignore the warning about the charge and save the file with a proper 
name (1t64_lock.pdbqt), ignore the Zn zero charge warning and click OK. 
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In a UNIX shell edit the 1t64_lock.pdbq file and correct the Zn charge into +2.0. 
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1.2.4. Preparing the GRID parameter file and running Autogrid4. 
 
The grid parameter file tells Autogrid4 which receptor to compute the potentials around, 
the types of maps to compute and the location and extent of those maps.  
1.2.4.1. Selecting the map types. 
In general, one map is calculated for each atom type in the ligand plus an electrostatics 
map and a separate desolvation map. The types of maps depend on the types of atoms in 
the ligand. Thus one way to specify the types of maps is by choosing a ligand. If the 
ligand you formatted in 1.2.2 is still in the Viewer use this procedure:  
Grid - Set Map Types - Choose Ligand … - 1t64_key - Select Ligand. 
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1.2.4.2. Setting the grid box. 
The central position and size of the grid docking box is set using the following procedure: 

Grid - Grid Box … 
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Set the center of the grid in the center of the ligand (key) and zoom out in the ADT main 
window (to zoom out ctrl+middle mouse button or ctrl+c and n keys for the full view) 
to check the size of the grid you are making. Turn off the lock molecule display (Display 
- Show/Hide molecule…) and re-center the view (ctrl+c and n keys). 
 

 
 
As you can see the TSA is almost fully embedded in the grid, but the size is not big 
enough to allow a free rotation of the molecule. As a rule of thumb the grid size should be 
as large as at least twice the double of the maximum distance you can measure between 
any two atoms of the co-crystallized ligand.  
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In the case you do not have any ligand position information the grid should be centered in 
the putative binding site and sized to embrace all the residue making the binding pocket. 
To set up the grid size you can inspect it visually and adjust the dimension by using the 3 
thumbwheel widgets. So for instance the suitable grid size should be 54 x 58 x 74 points 
using the default grid spacing of 0.375. Adjust all the values and save the information, 
save the gpf file and check the written file. 
 

(Grid option): File - Close saving current 
 

 



 21 

(Autodock Tools): Grid - Output - Save GPF… 
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NOTE. How to determine grid center and number of points? 
In the utilities folder you will find a python script called box.py that helps in calculating 
the grid center and the number of points. This utility also helps in the building of a PDB 
file that can be visualized in any molecular visualizer (i.e. VMD). The output of the 
box.py utility has to be saved to a filename.pdb file as described in the output itself. 
In a UNIX shell type: 
 
   Python box.py 1T64.gpf  > box.pdb 
You can visualize the output file using VMD 
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1.2.4.3 Run autogrid4 to make the grid maps. You can easily start a job from the 
command line 
 
Giving the following: 
 
 
 
 
After a few minutes the job will stop and a “done” message will return. Check the list of 
the file and you will notice that a number of new files have been created; those are the 
grid map files that autodock4 will use for the docking. 
 
 
 
 
 
 
 
 
 

Prompt> autogrid4 –p 1t64.gpf –l 1t64.glg & 
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1.2.5. Preparing the docking parameter file and running Autodock4. 
 
The docking parameter file tells AutoDock which map files to use, the ligand molecule to 
move, what its center and number of torsions are, where to start the ligand, the flexible 
residues to move if sidechain motion in the receptor is to be modeled, which docking 
algorithm to use and how many runs to do. It usually has the file extension, ".dpf". Four 
different docking algorithms are currently available in AutoDock: SA, the original Monte 
Carlo simulated annealing; GA, a traditional Darwinian genetic algorithm; LS, local 
search; and GALS, which is a hybrid genetic algorithm with local search. The GALS is 
also known as a Larmarckian genetic algorithm, or LGA, because children are allowed to 
inherit the local search adaptations of their parents. 
 
Each search method has its own set of parameters, and these must be set before running 
the docking experiment itself. These parameters include what kind of random number 
generator to use, step sizes, etc. ADT lets you change all of these parameters, and others 
not mentioned here.  
 
(Taken from the online ADT tutorial). 
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1.2.5.1. Preparing the dpf file. 
 
To set-up the dpf file follow this procedure: 
Docking - Macromolecule - Set Rigid Filename… 
Docking - Ligand -Choose… 
And select 1t64_lock.pdbqt and 1t64_key as the macromolecule and ligand filenames, 
respectively. 
Accept all the suggested setting in the AutoDpf4 Ligand Parameters window 
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Now let’s set the searching and docking parameters; we will use GALS and for this 
exercises all the default value will be let unchanged (only the ga run will be increase to 
100). Save the file as 1t64.dpf and check the written files. 
 

Docking → Search Parameters → Genetic Algorithm… 
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Docking → Docking Parameters… 
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Docking → Output → Lamarckian GA… 
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1.2.5.2 Run autodock4 to launch the docking. You can easily start a job from the 
command line giving the following: 
 
 
 
 
 
After some minutes with the set docking parameters the job is over and a “done” message 
appears. Using a modern CPU the job will take about 10-15 minutes to stop. 
 
 
 
 
 
 
 
 
 
 
 

Prompt> autodock4 –p 1t64.dpf –l 1t64.dlg & 
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1.3. Analyzing the docking results. 
 
Reading a docking log or a set of docking logs is the first step in analyzing the results of 
docking experiments. (By convention, these results files have the extension ".dlg".) 
 
During its automated docking procedure, AutoDock outputs a detailed record to the file 
specified after the -1 parameter. In our example, this log was written to the file 'ind.dlg'.  
 
The output includes many details about the docking which are output as AutoDock parses 
the input files and reports what it finds. For example, for each AutoGrid map, it reports 
opening the map file and how many data points it read in. When it parses the input ligand 
file, it reports building various initial data structures. After the input phase, AutoDock 
begins the specified number of runs. It reports which run number it is starting; it may 
report specifics about each generation. After completing the runs, AutoDock begins an 
analysis phase and records details of that process. At the very end, it reports a summary 
of the amount of time taken and the words 'Successful Completion'.  
 
The level of output detail is controlled by the parameter "outlev" in the docking 
parameter file. For dockings using the GA-LS algorithm, outlev 0 is recommended. 
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The key results in a docking log are the docked structures found at the end of each run, 
the energies of these docked structures and their similarities to each other. The similarity 
of docked structures is measured by computing the root-mean-square-deviation, rmsd, 
between the coordinates of the atoms. The docking results consist of the PDBQT of the 
Cartesian coordinates of the atoms in the docked molecule, along with the state variables 
that describe this docked conformation and position. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 35 

1.3.1. Load the results 
 
Before starting this section, you should undisplay any molecules in the Viewer using the 
Display → Show/Hide Molecule 
And follow this procedure: 
Analyze → Docking → Open… 
Analyze → Conformations → Load… 
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1.3.2. Visualize the results. 
Follow this procedure: 

Analyze →Conformations → Play 
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1.3.3. Clustering the results. 
 
An Autodock docking experiment usually has several solutions. The reliability of a 
docking result depends on the similarity of its final docked conformations. One way to 
measure the reliability of a result is to compare the rmsd of the lowest energy 
conformations and their rmsd to one another, to group them into families of similar 
conformations or "clusters". 
 
The dpf keyword, analysis, determines whether clustering is done by AutoDock. As you 
will see below, it is also possible to cluster conformations with ADT. By default, 
AutoDock clusters docked results at 0.5Å rmsd. This process involves ordering all of the 
conformations by docked energy, from lowest to highest.  
 
The lowest energy conformation is used as the seed for the first cluster. Next, the second 
conformation is compared to the first. If it is within the rmsd tolerance, it is added to the 
first cluster. If not, it becomes the first member of a new cluster. This process is repeated 
with the rest of the docked results, grouping them into families of similar conformations. 
 
First we will examine the AutoDock clustering that we read in from 1t64.dlg file. Next 
we will make new clusters at different rms tolerance values. 
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1.3.3.1. Displaying the Autodock clustering. 
 

Analyze → Clustering → Show… 
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1.3.3.2. Changing the clustering. 
 

Analyze → Clustering → Recluster… 
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The system seems that reach the convergence with ga_num_eval = 2.5M 
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2. Flexible docking (the new feature in autodock4). 
 
Inspecting the 1t64 complex it is possible to find that Tyr293 hydroxyl group is involved 
in a hydrogen bond with the carbonyl oxygen of the INH molecule. What if we allow the 
flexibility of Tyr293 in the docking? 
 

 

Tyr293 

INH 
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2.1. Preparing the files. 
 
Start ADT and follow this procedure: 
 
 
Flexible Residues →Input → Open Macromolecule… (Select 1t6a_lock.pdbqt) 
 
Select → Select From String (write TYR293) → Add 
 
Flexible Residue → Choose Torsions in Residue… 
 
Flexible Residue → Output → Save Flexible PDBQT…(write 1t64_lock.flex.pdbqt) → 
Save 
 
Flexible Residue → Output → Save Rigid PDBQT (write 1t64_lock.rigid.pdbqt) → Save 
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2.2. Preparing the parameter files for AutoGrid (gpf) and AutoDock (dpf) and 
running the AutoGrid and AutoDock programs.  
 
To do this you can sections from 1.2.4 through 1.2.5.2 if you prefer the graphical way 
using ADT. 
 
3.3. Results 
The run at ga_num_eval = 2.5M has converged and these are the graphical and clustering 
results: 
 

 


