Lab 4 - Importing Data and Basic Graphs

Often we will find data that is not in an excel format. This data could be in text format, or an alternate
spreadsheet or database format, and therefore needs to be converted into an excel format. This lab will
cover how to convert text files to excel files, as most data can be retrieved or converted into text form.

We will then learn how to use this data to create useful graphs.

LAB 4 QuicK VIEW

Text data can be imported into Excel in two ways:
o By opening the file through excel
o By selecting the “From Text” option under the “Data” menu
A wizard will open to guide you through importing the data
To insert a chart or graph into excel, highlight the required data and select the chart or
graph under the “Insert” menu
When editing graphs and carts:
o First check to see if there is a better chart or graph option for your data
o With the chart or graph selected, the “Chart Tools” and “Design” menu will let you
edit your chart or graph:
= The “Select Data” menu allows you to add data points to either the x- or y-
axis
= The “Add Chart Element” menu lets you add titles, gridlines, and trend lines
With the chart or graph selected, the “Chart Tools” and “Format” menu will let you
edit the appearance of your chart or graph
=  Colours can be changed in groups using this menu
= Colours can be changed individually by clicking on what you want to change.

MAKE SURE ANY GRAPH OR CHART YOU CREATE HAS ALL AXIS
CLEARLY LABELLED AND AN APPROPRIATE TITLE IS USED. THERE
SHOULD BE ENOUGH INFORMATION ON YOUR GRAPH SO A PERFECT
STRANGER WOULD UNDERSTAND IT.

41
© 2016 University of Alberta
Written by Lorne Priemaza



A)METHOD 1 - OPENING A TEXT DOCUMENT IN EXCEL

i) Perhaps the easiest method of converting text to excel is to open the text document in excel and
follow the prompts. When you open excel, choose “Open Other Workbooks” in the bottom left
when you first open excel, or “OPEN” on the left when you select “File”, then “Browse”.

[@¥ Open Other Workbooks Browse

ii) In the “OPEN” window that opens, change the drop down menu from “All Excel Files” to “All
Files”, then find and open the text document.

| Al Files -

| Open |v| | cCancal |

iii)  The Text Import Wizard will automatically open. By selecting options at the top, you will see how
the excel file will appear at the bottom. Different text files may require you to try different
options at the top. Usually, text is imported first using the “Delimited” option:

Text Import Wizard - Step 1 of 3 @

The Text Wizard has determined that your data is Delimited.
If this is correct, choose Mext, or choose the data type that best describes your data.
Original data type

Choose the file type that best describes your data:
@ Delimited - Characters such as commas or tabs separate each field.

(7 Fixed width - Fields are aligned in columns with spaces between each field.

iv)  After clicking next, you will choose how the data entries are separated in the text file. If commas
or semicolons (;) are used, select those options, then select and deselect “Tab” and “Space” until
the preview below correctly splits the columns.
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Text Import Wizard - Step 2 of 3 @

This screen lets you set the delimiters your data contains, You can see how your text is affected in the
preview below,

Delimiters

Tab
|:| Semicalon |:| Treat consecutive delimiters as one

Comma
g; Text gualifier: |~ IZI
Space

|:| Dthern

V) The final step of the wizard allows you to format the columns or delete columns. This is not
mandatory since we can do these steps inside excel itself.

B) Method 2 - USING THE DATA MENU.

i) If you have text data copied from another source (such as a text file or a webpage), you can
choose “GET EXTERNAL DATA, FROM TEXT” UNDER THE “DATA” menu.
File Home Insert Page Layout Farmulas Data
Show CQuerie
From Table
From From  From From Other Existing Mew .
Access Web [ Text ' Sources Connections | Quen Recent Sour
Get External Data Get & Transform
i) The wizard will appear as in method 1, with the additional pop-up asking you where you want

the data to be pasted in the spreadsheet (you are selecting the cell that will be the top left of
the data set). Alternately, you could paste the data into a new worksheet.

Import Data @

Select how you want to view this data in your workbook.,
B @ Table
PivotTable Report
I PivotChart
|:‘ Only Create Connection
Where do you want to put the data?
@ Existing worksheet:
=SA51| %

() New worksheet

|:| Add this data to the Data Model

o) [one
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C) BAR GRAPHS

To create a bar graph, simply highlight the columns of data you wish to use, including titles, then
under the “Insert” menu, select the “Insert Bar or Column” option under charts then under “2-D
Columns”, select “Clustered Columns”. The left column will be the default x-axis, but that can
be changed later.

Insert Page Layout Formulas Data Review

> 3 1% - Ie-

B
: : Wl -
wded Table Ilustrations Add- Recommended o .
les - ins~ Charts L AR
Charts

D)LINE GRAPHS

To create a line graph, simply highlight the columns of data you wish to use, including titles,
then under the “Insert” menu, select the “Insert Line or Area Chart” option under charts then
under “2-D Columns”, select “Line With Markers”. The left column will be the default x-axis, but
that can be changed later.

Insert Page Layout Formulas Data Review
) wY D 1% - IS
nded Table [lustrations Add-  Recommended m ||!I .
iles M ins - Charts = RN
Charts
E) PIE CHARTS

To create a pie chart graph, simply highlight the columns of data you wish to use, including
titles, then under the “Insert” menu, select the “Insert Pie or Doughnut Chart” option under
charts then under “2-D Pie”, select “Pie”. The left column will be the default pie labels and the
next column will determine the area of the pie, but that can be changed later. This simple Pie
chart can only be used to show one column of data.
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F) EDITTING GRAPHS

ii)

i)

v)

Your first step in editing a graph could be to change the type of graph you have selected. The
above graphs are suggestions only; feel free to choose another graph that may represent your
data better. For example, “Scatter Graphs” may work better for your data than “Line Graphs”.
Once you have chosen your graph type and have the graph selected, a new menu “Chart Tools”
with the submenu’s “Design” and “Format” will appear at the top. You can use these to edit
your graphs.

Design

If you want to change or modify what appears on the x or y axis, select “Select Data” under the
“Design” menu. You can start by trying the “Switch Row/Column” button. (A preview of the
new graph is shown.) Clicking the button again can undo the switch.

KA

Gl

Select Data Source

]
1

i

Chart data range: |='Econ 299 PRACTICE Lab 04'15A53:5C515

’ @ Switch Rowy/Column l

Legend Entries [Series) Horizontal [Category] Axis Labels

" 7 Add ” 7 Edit ”){Eemﬂ\fE] BH [7 Edit

In this “Select Data” menu, the “Series” refers to the points shown in the graph, and

represented by the y-axis, while the “Category” refers to the labels on the x-axis. To remove a
column from the graph (and all the graph points created by that column), select the column you
want removed and click on the “Remove” button on the left. To add another column’s data,
click on “Add” and highlight the column. To change what appears on the x- axis, select “Edit” on
the right and highlight what you would like as the new x-axis.

To add elements to the graph, use the “Add Chart Element” button under the “Design” menu.
Useful options are:

a) Inserting Axis if your data points have different units (for example, GDP and inflation)

b) Inserting Titles for the axis or graph. Titles can be formatting and changed by clicking
and typing directly on the title in the graph.

c) Gridlines can help make the graph more visible.

d) Trend lines can be useful to examine a relationship between variables.
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File Home Insert

]
]
IS (5% e.°
Add Chart Quick  Change
Element = |Layout = Colors~

Chart Layouts

vi) To quickly change all colours in the graph, use the “Change Colors” button. To change the
colour of just one element, click on that element, then under the “Format” menu, use the paint

jar tool to choose a different colour.

Chart Tools

Format

E - o
Quick
Q@ | Siyles Eil; Sel
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A)

B)

Econ 299 Practice Lab 4:
Grades and Graphs

Download or copy the following TEXT file showing midterm and final grades for an Econ 298
class. Using any method, import this data into excel, making sure each data set/variable is a

separate column.
Econ 298 Grades

Student Midterm Final
Tilda storm 7.0 64,38
soren Kierk 65.72 71.1

Manuel Kant 61.01 57.23
Adam smith 6l.92 66,57
Zee Garcia 50.13 44,19
sam Healey 9g. 28 a7.4a7
Danny Targ 89,97 47.4

John Snow 30.6 15.49
Fred Flint 52. 386 27.4

Barney Rub 34,17 17.57
Iron Man 6l1.31 59. 98

Adam warlock 63.73 6l1.69

Create a bar graph showing each student’s grades. Create an appropriate title on the x- axis and
y-axis, and give the graph an appropriate title. Since the final grade is very important, change
the final grade bars to be red.

Let’s assume that John Snow’s grades are particularly important. Change the colours of his
grades, and replace his name with capital letters. (Hint: Typing in the excel boxes that created
this graph will affect the graph itself.)

Now create a graph that puts final grades on the y-axis and midterm grades on the x-axis (hint:
you may need to use a “Scatter” graph, and use the “Select Data” button to place the right data
in the right axis.). Create appropriate x, y, and graph titles, and change John Snow’s data point
to a different colour. Insert a trend line to examine the relationship between midterm and final
marks for this class.

Consider the following extended grade information on John Snow, as well as how much each
component is worth towards the final Econ 298 grade:
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A E C D
1 |John Snow's Econ 298 Grades
2
3 (Component Grade Weight Resulting Mark
4 |Assignments 96 20%
5 |Labs 77 15%
& |Midterm 30.6 25%
7 |Final 15.49 40%
B e
9 Total 100%
10| |

F) In column D, calculate each component’s impact on John’s final mark (for example, getting 50%
on the final would result in 20% towards the final mark — 40% x 50%). Sum column D to find
John’s course mark.

G) Create two pie charts, one showing the weight distribution of the class (column C), and the
other showing how John's final course mark was divided (column D). Create appropriate titles,
and make sure each part of the pie is properly labelled, and percentages indicated. (Hint: right
click on the pie chart and select “Add Data Labels” to add percentages to the chart.)
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Econ 299 Practice Lab Answers:

(Certain title and formatting choices may be different.)

A E C E G H I J K
1 |Econ 298 Grades
2 . :
3 |student Midterm |Final Econ 298 Midterm and Final Grades
4 |Tilda Storm 77.01  64.38 120
5 |Soren Kierk 65.72 711 F 1$
& |Manuel Kant 61.01 57.23 E &0
7 |Adam Smith 61.92  66.57 ® o
= L s N ulll
9 |Sam Healey 98.28 97.97 0
10 |Danny Targ 89.97 47.4 & (ﬁo & & @ & \p"‘ &
11 [JOHN SNOW 30.6]  15.49) & cﬁ&"‘ & & \0@1 & q;gp \@ &
12 |Fred Flint 52.36 27.4 w
13 |Barney Rub 34.17 17.57 Students
14 [Iron Man 61.31 59.96
15 |Adam Warlock ~ 63.73  6L.69 w Midterm m Final
16 |
17
18 | Econ 298 Midterm and Final Grades
19 | 120
20
21' 100
22_ o BO
23| k] «*
24| e ”*
25 i
26 .
2?' 20 - ®
28 | D
29 ] 20 40 60 100 120
3[1_ Midterm Grades

i)
jury
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John Snow's Econ 298 Grades

Component Grade Weight Resulting Mark
Assignments 96 20% 15.2
Labs 77 15% 11.55
Midterm 30.6 25% 7.65
Final 15.49 40% 6.196

Total 100% 44.5936
| |

Econ 298 Mark Distribution

m Assignments = Labs = Midterm = Final

John's Econ 298 Mark Sources

m Assignments = Labs = Midterm = Final
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