
 

EDIT202 – Spreadsheet Lab 
Assignment Guidelines 
 
 
Getting Started 
 
 

1. For this lab you will modify a sample spreadsheet file named “Starter-
Spreadsheet.xls” which is available for download from the Spreadsheet lab 
page on the course WebCT site.  The link to this file is listed under the 
Needed Files section of the basic lab. 

 
 

• Download this file to the computer (if you are working from lab on campus 
be sure to select Save As … from the File menu and save it to a safe location 
that will not be deleted upon re-start). 

 
 
 

2. Using Microsoft Excel create a marking spreadsheet of a fictional class that 
meets the following guidelines.  Name this file “LABSEC-CCID-
SpreadSheet.xls”. 

 
 
 

• To launch the Microsoft Excel program, locate the Microsoft Excel icon, 
and double click.  

 

• To launch the program from the Start menu in the ED South 155 lab you 
can select Start > Programs > Microsoft Office > Microsoft Excel 2003. 
 

• Once you have launched Microsoft Excel you should see the program 
interface with a blank worksheet labeled “Workbook1”. 

 

 



 

• Choose File > Open, then browse for the saved sample spreadsheet that was 
downloaded from the course WebCT site. 

 
 
 
 

3. You will need to make sure that the following toolbars are available in order 
to be able to complete all of the steps in the tutorial: 
Standard, Formatting, and Drawing 

 
 

• Using the View menu choose Toolbars check of the name of a toolbar to 
add it to view. 
 

 

Worksheet 1 
 

 
4. Create columns to calculate the percent for each raw mark 
 

 
 
 

    4a.  Insert a new column to the right of each “Raw Marks” column  
 

 

 

• To insert a new column, left click inside any cell on the right side of where 
you wish the new column to appear (new columns are inserted to the left of 
the selected cell or column). 

• Choose Insert > Columns 
 
 
 

    4b.  Enter “Percent” in the column header of each new column 
 

 
 

• To enter information into a spreadsheet, click the mouse on the cell where 
you want data to appear, then type. 

 



 

 
 

 
 

     4c. In the “Percent” columns, create a formula that will calculate the first 
student's percentage for that assignment or exam (Raw Mark / Marked Out 
Of).   Use relative and absolute cell referencing. 

 
 

 
• In order to properly use formulas all formulas must start with an equal sign, 

e.g. =B5-B20.  
 
• When typing in formulas, the formula should be typed where you want the 

result to be displayed.  For example in the sample sheet below to calculate 
the first percentage the correct formula would be, =A2/B6 and the formula 
would be typed in cell B2. 

 
 

 
 

• As an alternate to typing out each cell reference you can use your mouse.  
Once you begin a formula by entering an equal sign, then click your mouse 
on a cell you wish to use as a cell reference.  You should notice that the cell 

 



 

reference is automatically entered into the formula.  (This means when you 
are done your formula hit enter on the keyboard instead of clicking on 
another cell.) 

 
• A relative cell reference is automatically adjusted when copying a formula 

to other cells. For example, if the following formula, = A1+B1 was copied, 
from cell C1 down to C2, the formula when copied would change to = 
A2+B2 

 
• An absolute cell reference refers to a value that does not change when 

being copied to other cells. For this example the same formula as above will 
be used but with one small change: absolutes will be added to the row values 
in the formula. In Microsoft Excel absolutes are represented as dollar signs, 
$). 

 
• The absolute value in the percentage equation is the Marked Out Of value 

in cell B32.  This is the value that each of the students’ Raw Scores will be 
divided by.  

 
• Using this information it will be up to you to think of where to place the 

absolute ($). 
 
 
 

    4d. Copy the formula down the column so that it determines the percentage 
for each student.   

 
 

• To copy a formula, click on the bottom right-hand corner of the cell that 
needs to be copied and a little black crosshairs will appear.   

 
• Drag down to include all the cells in the range. 

 
• Release the mouse and we see our formula successfully copies with the 

correct results in our chosen cells. 

 



 

 
 

    4e. Format each students’ percentage to be displayed in percent format and to 
include one decimal place (e.g. 65.4% not 0.654).  

 
 

• To get all of the numbers on your spreadsheet displayed in a consistent 
manner, such as an equal number of decimal places, you need to set a 
number formatting option.  

 
• To do this, first highlight the whole block of cells you want to format. The 

cells do not need data in them to complete this step; any data entered later 
will be formatted in this manner. 

 
• You can then set the number of decimals in two ways:  

 
o Click once on the Increase Decimal button on the formatting toolbar. 

 

 
 

o The other way of adding decimals is to click on the Format menu, 
then click on Cells. Click on the Number tab, set the options as 
shown below, then click the OK button. 

 

 

 



 

 
• In this window, the data can be formatted to look like currency with a $, or 

like percentages with a %.  The results of our formulas or any other data can 
be formatted on our sheet to look like any type of data by selecting a 
different Category and setting different options. 

 
 
 
 

5. Create a column to calculate the overall final mark for each student. 
 

5a. In the column to the right of the Final Exam Percent column enter the 
column header “Final Mark” 

 
5b. Create a formula to calculate students’ final weighted mark ((Assignment 1 

Percent X Assignment 1 weight) + (Assignment 2 Percent X Assignment 2 
weight) + …... + (Final Exam Percent X Final Exam weight)) 

 
5c. Format the results for each student’s final mark to be displayed in percent 

and to include one decimal place e.g. (65.4% not 0.654). 
 
 

 
6. Create a new column to display if students received honors or not. 
 
6a. In the column to the right of the Final Mark column enter the column header 

“Honors” 
 
6b. Insert a formula that will display an “H” in the “Honors” column if the 

student got a final mark that is equal to 80% or higher and will display an 
“R” if they did not get a mark over 80%  
(Hint: you will want to use the “IF” function” to do this) 
Note: Ensure that a mark of exactly 80% receives honors 

 
Some helpful symbols for you: 

>         greater than 

<         less than 

>=      greater than or equal to 
              <=      less than or equal to 

 



 

 
• If you have never used functions within Excel, it is recommended at this 

point that you go to the Functions section of your Prep Sheet read up on 
them. 

 
• To insert a function into a cell, click on the cell, then select Function from 

the Insert menu. This opens the Insert Function window.  
 
• Choose the desired function, and click OK. If you can’t find the function 

you are looking for select the All category and you will see all functions 
listed in alphabetical order. 

 
• Your current assignment also makes use of the "IF" function, specifically to 

determine whether or not students will receive honors. 
 
• The "IF" function is referred to as a conditional function.  A conditional 

function can return different results based on a certain condition being 
evaluated to True or False.  
 

 

 
 

 
• The "Logical_test" text box shown in the above screenshot is where you 

type the condition that will be evaluated.  
 

 



 

• So if that condition proves to be True we can get it to return a certain result, 
and if that condition proves to be False then we can get it to return a 
different result. 
 

• NOTE: The following is an example of using the IF function.  Refer to step 
6b in the grey box above for the criteria you should use in this assignment. 

 
• What is being tested in the example (please note this is only an example and 

will differ that what is needed for your assignment) shown below is whether 
or not the value in cell A5 is greater than 10 by typing "A5>10" in the 
"Logical_test" text box. 

 

 
 

• So on the spreadsheet the phrase, "Yes the number in A5 is more than 10", 
would appear in the cell we selected before opening the function wizard.  

 
• If the value in cell A5 was less than 10 then the condition would be 

evaluated as "False", and the statement, "No the number in A5 is not more 
than 10" would appear in the cell we selected before opening the function 
wizard. 

 

 



 

 
 
7. Sort the students on your spreadsheet in ascending according to their ID 

number. (Note: be sure that the students’ data gets sorted along with the ID 
numbers, otherwise you will mix up which marks go with which student) 

 
 
 

• First, indicate which data in the spreadsheet is to be sorted. Select the range 
of data you want to sort, making sure that all the data you want to move as a 
result of the sort has been selected. 

 
•  Select Sort from the Data menu. 

 

 
 

• The Sort options window appears. Choose either Header row or No header 
row, based on whether or not you included the column headings when you 
selected your sort data. Selecting the Header row option will in fact 
eliminate the top row of your sort data in an attempt to remove the column 
headings from your sort.   

 
• From the Sort by drop down menu, choose which column you want to sort, 

then choose to sort it in Ascending or Descending order. Once finished, 
click on OK and view your sheet to make sure the data has been sorted 
correctly.  

 

 



 

 
 
 
 

8. Bold the main title and change the font and size to Arial 24.   Merge and 
Center the title across all of the columns containing data in the spreadsheet. 

 
9. Bold the individual column headings as well, and merge and center them 

across the two columns for each assignment and exam (raw mark and 
percent). 

 

 
 

 
 
• To format the data on your sheet there are a few different options. First, 

select the cell or range of cells you want to format. 
 

• You can use the available buttons on the formatting toolbar. 
 
 

 
 
 

• You can also select Cells from the Format menu then select the Font tab to 
change the font size, style, or color. There are many more options when you 
use Format Cells, however using the formatting toolbar is quicker and 
more convenient. 

 

 
 

 
• Merging cells is where you take a range of cells and merge them together as 

if they are one cell.  An example of merged cells is shown below. Cells A1 
through G1 of a sheet are merged (treated as if they were one cell), and the 
text is also centered within this larger cell area. 

 
 

 



 

 
 
 
• To merge data we first need to select the cells we want to merge.  Start by 

clicking on the cell which contains the content you wish to keep.  Then 
continue selected the range of cells you wish to merge into one.   

 
• Then with the cells highlighted, use the Merge and Center button found on 

the formatting toolbar. 
 

 
 
 

 
10.  Format the borders around all cells of your sheet in the following way: 
 

• Thin borders between the cells 
 

 
 

See sample assignment for full example 
 
 
 

• To set borders, first select the range of cells around which you want to put 
borders. 
 

 



 

• Now select Cells from the Format menu and choose the Border tab.  
 

 
 
• To select your borders you first select the line style. With the current line 

style selected, click on the border you wish to apply it to within the border 
display box.  Continue this process until all your borders are created.  

 

 

Second: 
Choose a 
border 

First: 
Select a 
line style 

 
 

 



 

• Select the range of cells you wish to format and then select Cells from the 
Format menu then select the Patterns tab to change the background color 
of a cell.   
 

 
 

 
 
 

11.  Insert Cell Comments (as listed below in “ ”) into the following cells  
• Cell C3 (Assignment 1): “Statistics Project” 
• Cell E3 (Assignment 2): “Finance Project” 
• Cell G3 (Assignment 3): “Design Project” 
• Cell N3 (Honors):  “H = honors   R = regular   Honors is awarded to a 

final mark of 80% or higher” 
 

 
 
 

• To add a comment to a cell, click in the cell to which you want to add the 
comment and select Comment from the Insert menu. 

 
• In the comment box, type your comment text. When you finish typing the 

text you can single click on the edge of the box to place it in a different 
location.  When you are happy with the placement, single click outside the 
comment box.   

 
• Wherever the comment box is placed will be where it will appear when you 

drag your mouse over the cell that has the comment. 
 

• To edit an existing cell comment, click the cell with the comment you want 
to edit, and select Edit Comment from the Insert menu. 

 



 

 
 

12. Rename this worksheet “Student Marks” 
 

 
Note: 

• An Excel document is called a “workbook”.  A workbook can contain many 
“worksheets”.  What you have been currently working on is one worksheet 
(currently named Sheet 1) within your LABSEC-CCID-spreadsheet.xls file. 

 
• If you look at the bottom-left portion of the Excel program window you will 

see the following navigation arrows and tabs: 
 

 
 
• The tabs represent worksheets; the bolded tab is the worksheet you are 

currently looking at.  You can navigate between worksheets by clicking on 
the tabs. 

 
• To rename an Excel worksheet right-click on the worksheet tab at the 

bottom of the screen and choose “Rename” from the context menu, then type 
in the new name. 

 
 

• At this point it would be useful to compare your “Student Marks” worksheet 
with the same worksheet in the sample file (linked on the WebCT 
assignment page).   

 
• You’ll want to particularly scrutinize the results of your formulas and verify 

all the numbers match up. (In a real-world scenario, you would have to do 
this verification against some numbers you calculate yourself by hand or 
calculator) 

 

 



 

Worksheet 2 
 

 
 
13.  Start work in a new worksheet and name it “Assessment Statistics” 

 
 

 
 
14.  Inside the “Assessment Statistics” worksheet, type in the following row and 

column headers:  
 

 
 

15.  Format column and row headers to be bold 
 

16.  Format borders: thin borders inside.  
 

17.  Format the column widths so that all the text is visible in every cell 
 
 

 
• There are several ways to format column width and row height.  
  

o You can click on a cell in the desired column, the choose Format > 
Column > Width and manually enter a width. 

 
o You can place the cursor directly over the line that divides two 

column titles so that the cursor become a double-headed arrow, then 
click and hold down the left button to resize the column 

 

 



 

 
 

 
 

 
18.  In the row titled “Class Average” insert functions that calculate the average 

mark for each assignment and exam.  Format the results to display in percent 
with one decimal place. 
(Hint: use the AVERAGE function) 

 
 

• Inserting these functions is the same process as you have done in step 6.  
The only difference is that you will have to reference cells on a different 
worksheet 

 
• When you wish to reference a cell or cells from another worksheet select the 

desired worksheet and then click on the cell you wish to reference.  You will 
notice that the cell information will automatically be inserted into your 
formula or function. 

 
 

 
19.  In the row titled “Below 50%” insert functions that calculate the number of 

marks below 50% for each assignment and exam. 
(Hint: use the COUNTIF function) 

 
 

• If you can’t find the COUNTIF function, change the category to “All” 
and search for it alphabetically 

 

 



 

 
 

 
 

 
20.  In the row titled “90% and above” insert functions that calculate the number 

of marks above 90% for each assignment and exam 
(Hint: use the COUNTIF function) 

 
 

 
 
21.  In the row titled “Between 50% and 90%” create a formula that calculates 

the number of marks equal to 50% and up to 90%. 
(Hint: COUNTIF will not evaluate two criteria at once.  So you will need to 
insert a function, then subtract another function from it) 

 
 
 

 
22.  Insert a pie chart in the “Assessment Statistics” worksheet that compares the 

number of students within the 3 different ranges of marks for the Final Exam 
(Below 50%, Above 90%, Between 50% and 90%). 

 
• chart title: Final Exam Analysis 

 
• insert as object within the worksheet 

 

 



 

 
• To create a chart in Excel first select the cells that contain the data that you 

want to appear in the chart. If you want column and row labels to appear in 
the chart, include the cells that contain them in the selection.  

 
• To select more than one range of data, click and drag to select one range, 

and make sure it is highlighted. Then hold down the CTRL key on your 
keyboard and click and drag to select the next range of data.   

 
• For our assignment the cells to select would look like this: 

 

 
 
• Once you have your data ranges selected, click the Chart Wizard button on 

the standard toolbar, or select Chart from the Insert menu. 
 

• Fill in the necessary information and click NEXT to move to the next 
options window 

 
Note: If you created the pie chart but did not include the category labels 
(“Below 50%”, “90% and Above”, “Between 50% and 90%) then you will need 
to add them.  To do this: 
 

• right-click on the chart and choose Source Data  
 
• choose the Series tab 

 



 

 
• click inside the box for Category Labels 

 
• Now highlight the three categories on your spreadsheet.  This should 

automatically enter them into the chart. 
 

• Click OK 
 
 

 
Worksheet 3 

 
 

 
23.  Create a line chart that tracks the class averages for all assignments and 

exams and meets the following criteria: 
 

• marks data is along the Y-axis and that the range is 0% - 100% 
 
• X-axis labels: the assignment descriptions 
 
• Chart Title: Class Average 
 
• Chart created on a separate sheet labeled “Student Marks Chart” 

(you can specify this at Step 4 of the Chart Wizard). 
 

• All other chart options can be added but are considered optional. 
 
 
 

• The initial selection for this chart would look like this: 
 

 

 



 

 
 

 
• Again, once you have your data ranges selected, click the Chart Wizard 

button on the standard toolbar, or select Chart from the Insert menu. 
 
• Follow the same steps as with the pie chart. 

 
• When Step 4 of the chart wizard appears. You can insert your chart as a new 

sheet in your workbook or as a separate object, like a piece of Clip Art 
that is placed into an existing sheet. Click on the As new sheet radio button 
the click on the Finish button. 
 

 

 
 
 
• If you wish to further customize any part of the chart right-click on it and 

use the menu options available. 

 



 

 
• For example you will want to change the range of the Y-axis to be 0%-

100%.  To do this: 
 

 
o Right-click anywhere among the percents displayed in the X-axis. 
 
o The Format Axis window appears. Choose the Scale tab and make 

your changes. 
 
 
 

Cell Protection 
 
 

24.  Modify your Student Marks worksheet so that only the cells with Raw 
Data (ie. Student Name, Student ID, Raw Marks for all assignments and 
exams) can be modified or have data entered into them when the sheet is 
protected. 

 
 

• First select the ranges of data on the sheet you want to be able to edit after 
the entire worksheet has been protected. Select Cells from the Format 
menu. 

 
• The Format Cells window should appear. Click on the Protection tab. 

Click in the box next to Locked to remove the check mark. Click OK. You 
have now set the Locked property for these cells to false.  In other words 
you have unlocked these cells. 

 
 

 
 

 

 



 

• Our next step is to protect our entire worksheet.  From the Tools menu select 
Protection > Protect Sheet. 

 
• The Protect Sheet window appears. Leave the options as they are and click 

OK.  This ensures that every object on your sheet, aside from the ranges of 
cells you unlocked, will be unchangeable after the sheet has been protected. 

 

 
 

• To protect other objects or set options on your sheet, single click to add a 
checkmark in the above check boxes. 

 
• You also have the option to assign a password.  This way only the people 

that know the password will be able to unprotect the worksheet and make 
changes.  However, if you are ever submitting a spreadsheet for marking 
you do not want to set a password.  The person marking your sheet will 
need to unprotect it in order mark it. 

 
• Now if you try to alter the contents of any of the locked cells, you will not 

be able to.  You should, however, be able to modify the data in the unlocked 
cells. 

 
• If you want to change the locked property of cells, the worksheet must be 

unprotected. Thus, once you have protected a sheet, you must unprotect it 
before you can modify the locked settings or any other settings. 

 



 

 
• To remove protection from a worksheet, select Protection > Unprotect 

Sheet from the Tools menu. If you entered a password, you will be 
prompted to enter the protection password for the worksheet. 

 
• To move between unlocked cells on a protected worksheet, click an 

unlocked cell, and then press the Tab key. The Tab key is a handy way to 
let you cycle through the unlocked cells of a sheet. 

 
 

 
25. Submit your “LABSEC-CCID-SpreadSheet.xls” file in WebCT. 
 

 
 
 
 
Steven Scott & Jeff Warner 
University of Alberta 
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